Mailing List CGatePro@mail.stalker.com Message #105120
From: Urs Grützner <ugruetzner@ems.ch>
Subject: Re: Empty Subject instead of tagging
Date: Sun, 24 Aug 2014 13:57:03 +0200
To: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>
X-Mailer: Apple Mail (2.1510)



Technical Support <support@communigate.com>
Subject:Re: Empty Subject instead of tagging
Date:Thu, 21 Aug 2014 12:49:22 +0400
To:CommuniGate Pro Discussions <CGatePro@mail.stalker.com>
Hello,

On 2014-08-17 19:40 , Urs Grützner wrote:
I wrote a very simple rule to tag a subject, when the mail is addressed to a certain recipient (filemaker@ems.ch)


According to the log the rule is evoked, but the subject of the mail is completely empty. The original subject and the tag are missing.

info <info@ems.ch>
An: filemaker@ems.ch
Antwort an: info@ems.ch
(Kein Betreff)
16:01:21.469 2 QUEUE([5648818]) from <info@ems.ch>, 868 bytes (<FileMaker.53f0b5b1.b.14501@>)
16:01:21.532 4 LOCALRULES(info) rule(Filemaker) conditions met
16:01:21.532 2 LOCALRULES(info) [5648818] rule(Filemaker): subject tagged: '[FM-INFO]'

It may be that the original mail did not have the Subject header at all?



No thats not the case, the subject is never empty in the originals (these are both mails generated from two different servers). And even when it would be empty, the tag should be present in the modified subject.



The weird thing: the same rule, when evoked by mails with a different return path is working correctly!: the tag is added before the original subject, as expected.

Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster