Mailing List CGatePro@mail.stalker.com Message #106070
From: Technical Support <support@stalker.com>
Subject: Re: CGP 6.1.10 & ActiveSync search on iDevice - Case[ABLH0505-726MY]
Date: Fri, 6 May 2016 11:38:13 +0300
To: Terrence Koeman <terrence@darkness-reigns.com>, CGatePro@mail.stalker.com <cgatepro@mail.stalker.com>
Hello,

On 2016-05-05 21:58, Terrence Koeman wrote:
Hi all,

Recently I upgraded CGP from 6.1.8 to 6.1.10, and since then I've
noticed (and received reports) of issues with the search results on
iPhones & iPads using ActiveSync.

Search results show a lot of old emails that are not in the account
anymore (iDevice says the message isn't downloaded and it can't
download it as it's not in the account) as well as duplicate results.
Of the duplicate results only one will be a real email that can be
opened.

The results of the search command may contain mails that are out of the synchronization period chosen in the device settings. To retrieve the bodies of those emails the devices issues additional command to retrieve the body and CGPro handles that.
If you experience problem with  viewing found emails, then please try to reproduce them with AirSync and HTTPU loge level set to All Info and send us thelogs key-filtered on the device ID.

It seems CGP is returning search results from some old index or
cache. It's really a problem as in any given search well over half
the hits are for old emails that aren't available and duplicates that
can't be opened. The iDevice knows they aren't available because I
can't select these in 'Edit' mode either (no select circle).

Only the mailbox contents are used for the search, but the result may include mails that are beyound the synchronization period.

My Outlook is configured to autoarchive/move all email older than 3
months from the server to a local PST file. However, searching on my
phone now shows much older emails in the results. I've checked and
these emails are definitely not on the server anymore. Outlook does
show proper search results (no old emails & no dupes).

Anyone else seeing this problem? Is there perhaps an index or cache I
can nuke to fix this?

Thanks in advance!


--
Best regards,
Dmitry Akindinov

=======================================================================
When answering to letters sent to you by the tech.support staff, make
sure the original message you have received is included into your
reply.
Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster