Mailing List CGatePro@mail.stalker.com Message #106169
From: Roberto Michelena <rmichelena@mac.com>
Subject: voice on browser Pronto
Date: Mon, 05 Sep 2016 00:19:34 -0500
To: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>
X-Mailer: Apple Mail (2.3124)
For whoever is interested in using browser-based Pronto for voice calls (not Flash Pronto, but HTML Pronto), here the results of some testing.
(Mac OSX browsers, latest versions, OS X 10.11.6 ).
CGPro latest version 6.1.11
Pronto HTML, enabled “receive calls” ; everything on local network, no internet, no NAT, no WAN address.
Using SSL (default port 9100); otherwise Chrome won’t connect, Firefox will be unusable (each call asking for microphone use)

FIREFOX: (not usable)
When logged in, pops up "would you like to share microphone and camera with (server address)"
you can "share always” and that’s done
it’s using “WebRTC Wrapper”
it’s unusable !! microphone input loops into speaker output and creates feedback, regardless of the other party!
option: install plugin (HDVoice): forget it, the plugin crashes always.

SAFARI: (not usable)
- does not support WebRTC so needs Plugin
- HDVoice plugin apparently crashes silently always
- if install WebRTC Plugin by Temasys, it does not use it anyway

CHROME and OPERA (same behavior)
WebRTC Wrapper 2.0, does not give option for Plugin
Everything seems to work ok, audio works.
Browser client calling another browser, ok ; browser client calling iOS client, ok; iOS client calling another iOS client, ok.
Exception: iOS client calling browser client, call connects but no audio.

Roberto

Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster