Mailing List CGatePro@mail.stalker.com Message #106632
From: Technical Support, Stalker Labs support@stalker.com <CGatePro@mail.stalker.com>
Subject: Re: TCP listener error after upgrading to 6.2.0
Date: Sun, 26 Nov 2017 17:01:08 +0300
To: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>
Hello,
On 26.11.2017 10:22, Paul_Dudley wrote:
We are running CommuniGate on  a Red Hat linux server. I upgraded from v6.1.16 to v6.2.0 today. The upgrade worked OK and CommuniGate restarted OK however after the restart I am seeing the following error message in red in the admin screen:

This is a new feature in 6.2 :-)

If you have an idea what other errors/events can be reported there, please tell us.
(the class of events reported there should something that is vital to the server and require admin's immediate reaction, like the mentioned one with inability to open ports; but not casual errors such as incorrect password or someone being blacklisted)

A problem with Module IMAP, TCP listener on [0.0.0.0]:573: failed to start. Error Code=network address/port is already in use

A problem with Module SMTP, TCP listener on [0.0.0.0]:587: failed to start. Error Code=network address/port is already in use

I have stopped and restarted the service again but the error message persists. I have run the “netstat” command but cannot see any process using ports 573 or 587. Neither sendmail nor postfix is running.

I suspect all those ports are used by CGPro, however by multiple modules at a time.

In the system log I am seeing the following entries:

18:10:28.00 1 IMAP failed to start TCP listener on [0.0.0.0]:587. Error Code=network address/port is already in use

18:10:28.00 1 SMTP failed to start TCP listener on [0.0.0.0]:587. Error Code=network address/port is already in use

18:10:28.00 1 IMAP failed to start TCP listener on [0.0.0.0]:573. Error Code=network address/port is already in use

Under Settings -> Services and Settings -> IMAP we have ports 573 and 587 enabled for listening.

The port 587 must be for SMTP rather than IMAP, please delete it from IMAP listener settings.

The 573 also doesn't belong to IMAP and may be used by some other protocol.


On 26.11.2017 10:35, Paul_Dudley wrote:

As a follow up to this – I downgraded back to v6.1.16 and the error message did not reappear, so it is something specific to v6.2.0

The message in red in admin screen is specific to 6.2; but messages in CommuniGate log - no, so you should still have them.


--
Best regards,
Roman Prokhorov
=======================================================================
When answering to letters sent to you by the tech.support staff, make
sure the original message you have received is included into your reply.
Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster