Mailing List CGatePro@mail.stalker.com Message #106889
From: Ralf Zenklusen, BAR Informatik AG r.zenklusen@barinformatik.ch <CGatePro@mail.stalker.com>
Subject: AW: DNS server failure - mail queue issue
Date: Fri, 13 Jul 2018 07:43:12 +0200
To: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>
X-Mailer: CommuniGate Pro MAPI Connector 1.52.54.12/1.54.12.21

Hi Paul,

That’s strange, I would expect that the emails would have failed and an error message would have been send back to the sender – at least pre 6.2.5.

 

In 6.2.5 this was added:

  • SMTP: DNS server failures to resolve remote hostnames are treated as non-fatal failures.

So, since then I would expect that the emails would stay in the queue until DNS works or retry time is over.

 

 

Yes, restart should help.

But would be good to know which version you’re using.

 

Regards

Ralf

 

 

Von: CommuniGate Pro Discussions [mailto:CGatePro@mail.stalker.com]
Gesendet: Freitag, 13. Juli 2018 06:24
An: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>
Betreff: Re: DNS server failure - mail queue issue

 

A very long time ago I had the same problem with an important msg stuck in the queue. I restarted CGP and it appeared to work.

I can't say whether or not it will work for you now but it is worth a try IMHO.

 

On 13/07/2018 2:13 PM, Paul_Dudley pdudley@anl.com.au wrote:

 

We have a number of outbound messages stuck in the sending queue. They were stuck there because of a DNS server failure error, trying to resolve a specific domain. I have since changed the sending SMTP server (under Settings -> Mail -> SMTP -> Sending, and messages sent to that same domain since I made that change are being sent OK.

 

I would have thought that these stuck messages would now attempt to be sent via the new outgoing SMTP relay server and now be sent, but in the log I still see the same errors:

 

DNR-009083(xx.xx.xx) MX:DNS server failure

DNR-009125(xx.xx.xx) A:DNS server failure

SMTP-078760(xx.xx.xx) failed to resolve 'xx.xx.xx':Error Code=DNS server failure

 

I have even fixed the DNS issue on the server itself (it can now resolve the domain correctly) and have re-released the queue but still these messages will not send.

Any ideas? Would stopping and restarting the CommuniGate service fix the problem?

 

 

 

 

Regards

Paul Dudley

pdudley@anl.com.au

 


ANL DISCLAIMER

This e-mail and any file attached is confidential, and intended solely to the named addressees. Any unauthorised dissemination or use is strictly prohibited. If you received this e-mail in error, please immediately notify the sender by return e-mail from your system. Please do not copy, use or make reference to it for any purpose, or disclose its contents to any person.



-- 
Shaun
Fitzroy Island <http://www.fitzroyisland.com> Cairns, QLD
Destination Darwin NT <http://www.destinationnt.com> Darwin, NT
MOM Backpackers <http://www.momdarwin.com> Darwin, NT
Value Inn Hotel <http://www.valueinn.com.au> Darwin, NT
Crocosaurus Cove <http://www.croccove.com> Darwin, NT
Please do not send any unsolicited email. It is not wanted. 
Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster