Mailing List CGatePro@mail.stalker.com Message #94664
From: Urs Gruetzner <ugruetzner@ems.ch>
Subject: Re: Strange rule behaviour
Date: Wed, 9 Apr 2008 15:21:52 +0200
To: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>
X-Mailer: CTM PowerMail version 5.6.2 build 4501 German (PPC) <http://www.ctmdev.com>
I would be very happy if someone could help me to bring light in this
misterious rule results

The rule is:

rule (for one account, named "applications" only):
- store a copy in INBOX/subfolderbyuser (depending of to-adress)
- keep the original in INBOX (i.e. no discard command)

There are two detailed logs (filtered by the message ID), the first for
the failed result, second as desired


I don't see any difference, especially I can't see any entry that the
message was delivered twice into INBOX/subfolderbyuser


Urs




an example which produced two messages in inbox/kaeser, no original left
in INBOX

14:12:46.83 4 LOCAL(applications) [1537993] enqueueing (new)
14:12:46.83 2 ENQUEUER-01([1537993]) enqueued
14:12:46.83 2 LOCALRULES(applications) [1537993] rule 'acknowledgement
Kae'(Reply) -> [1538016]
14:12:46.86 2 MAILBOX(applications/INBOX/kaeser) [1537993] stored as 6133
14:12:46.86 2 LOCALRULES(applications) [1537993] rule(kaeser) message
stored in 'inbox/kaeser'
14:12:46.88 2 MAILBOX(applications/INBOX) [1537993] stored as 4453
14:12:46.88 2 ACCOUNT(applications) [1537993] delivered
14:12:46.88 4 LOCAL(applications) [1537993] batch delivered
14:12:46.88 2 DEQUEUER [1537993] LOCAL(applications) delivered:
Delivered to the user mailbox
14:12:46.88 2 QUEUE([1537993]) deleted

Delivered as desired, one in INBOX, one in INBOX/Subfolder:


11:39:06.86 4 LOCAL(applications) [1535179] enqueueing (new)
11:39:06.86 2 ENQUEUER-01([1535179]) enqueued
11:39:06.88 2 LOCALRULES(applications) [1535179] rule 'acknowledgement
Gr'(Reply) -> [1535153]
11:39:07.21 2 MAILBOX(applications/INBOX/gruetzner) [1535179] stored as 4715
11:39:07.22 2 LOCALRULES(applications) [1535179] rule(gruetzner) message
stored in 'inbox/gruetzner'
11:39:07.39 2 MAILBOX(applications/INBOX) [1535179] stored as 4425
11:39:07.39 2 ACCOUNT(applications) [1535179] delivered
11:39:07.39 4 LOCAL(applications) [1535179] batch delivered
11:39:07.39 2 DEQUEUER [1535179] LOCAL(applications) delivered:
Delivered to the user mailbox
11:39:07.40 2 QUEUE([1535179]) deleted
*END*





From: Urs Grützner <ugruetzner@ems.ch>
Subject: Re: Strange rule behaviour
Date: Thu, 3 Apr 2008 20:52:44 +0200
To: "CommuniGate Pro Discussions" <CGatePro@mail.stalker.com>
X-Mailer: CTM PowerMail version 5.6.3 build 4504 German (intel) <http://
www.ctmdev.com>



>You need to set the LOCAL module log level (settings -> mail) and
Mailboxes log level (in domain
>settings) to All Info and run tests. The logs will show what exactly
happens with the messages.


I did. Below is the result of message 1524951 which was twice in INBOX/
gruetzner and zero in INBOX where one message acccording to the rule
should be.

according to the line

16:17:26.70 2 MAILBOX(applications/INBOX) [1524951] stored as 4359

one copy should be stored in INBOX, but it is not. Why?



Urs


6:17:01.77 2 SMTPI-24530(smtp2.net2000.ch) [1524951] received, 6988757 bytes
16:17:01.77 5 ENQUEUER-01([1524951]) envelope: P I 03-04-2008 14:16:44
0000 ____ ____ <pwyler@pwyler.ch>
16:17:01.77 5 ENQUEUER-01([1524951]) envelope: A ems.ch [212.74.146.1]
16:17:01.77 5 ENQUEUER-01([1524951]) envelope: S SMTP [80.83.47.190]
16:17:01.77 5 ENQUEUER-01([1524951]) envelope: R W 03-04-2008 14:16:44
0000 ____ _FY_ <gruetzner@ems.ch>
16:17:01.77 2 QUEUE([1524951]) from <pwyler@pwyler.ch>, 6988757 bytes
(<MPEILMHIKJNEABOOJLNPOEIBCKAA.pwyler@pwyler.ch>)
16:17:01.77 4 ENQUEUER-01([1524951]) applying server rules
16:17:01.77 4 EXTFILTER(CGPClamAV) out(29): 64910 FILE Queue/1524951.msg\n
16:17:23.32 4 EXTFILTER(CGPClamAV) [1524951] header added: X-CGP-ClamAV-
Result: CLEAN\nX-VirusScanner: Niversoft's CGPClamav Helper v1.74
(ClamAV engine v0.92.1)
16:17:23.32 4 EXTFILTER(find_attachments) out(29): 64809 FILE Queue/
1524951.msg\n
16:17:26.14 4 EXTFILTER(find_attachments) [1524951] header added: X-
AttachExt: pdf\nX-ExtScanner: Niversoft's Find_Attachments
16:17:26.14 4 EXTFILTER(Pollustop) out(29): 64809 FILE Queue/1524951.msg\n
16:17:26.16 4 EXTFILTER(Pollustop) [1524951] header added: X-PolluStop-
Diagnostic: (whitelisted)\nX-Orig-Return-Path: pwyler@pwyler.ch\nX-Orig-
Recipients: Yc9fZ9iE+xCvYQgIeVfwVCHv7aq/bf7W\nX-PolluStop-Score: 0.0\nX-
PolluStop: Scanned with Niversoft PolluStop v2.5.2a
16:17:26.16 4 LOCAL(applications) [1524951] enqueueing (new)
16:17:26.16 2 ENQUEUER-01([1524951]) enqueued
16:17:26.16 2 LOCALRULES(applications) [1524951] rule 'acknowledgement
Gr'(Reply) -> [1524948]
16:17:26.46 2 MAILBOX(applications/INBOX/gruetzner) [1524951] stored as 4701
16:17:26.46 2 LOCALRULES(applications) [1524951] rule(gruetzner) message
stored in 'inbox/gruetzner'
16:17:26.70 2 MAILBOX(applications/INBOX) [1524951] stored as 4359
16:17:26.70 2 ACCOUNT(applications) [1524951] delivered
16:17:26.70 4 LOCAL(applications) [1524951] batch delivered
16:17:26.70 2 DEQUEUER [1524951] LOCAL(applications) delivered:
Delivered to the user mailbox
16:17:26.70 2 QUEUE([1524951]) deleted




Mailing List CGatePro@mail.stalker.com Message #94544
From: Technical Support <support@stalker.com>
Subject: Re: Strange rule behaviour
Date: Tue, 01 Apr 2008 22:29:00 +0400
To: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>



Hello,

Urs Gruetzner wrote:
Yes there are multiple clients (max 8) using this account as IMAP. But
all rules are made by myself, on the server.


For 4 of us exists one subfolder in the inbox.


Rules:


Prio 7: Move Spam: Mails tagged as Spam by Pollustop are stored in one
Spamfolder, original discarded
Prio 6: Acknowledment: automated reply if To Address matches one of 4 aliases
Prio 5: Move to subfolder: four rules (which are subject of this topic).
Stores (a copy of) the message in one of the 4 subfolders, original
should remain in the inbox


There are no other active rules.


So nothing really complicated. I am somewhat surprised that CGP cannot
perform duly this task: sometimes the rules are working as desired,
sometimes also the original is moved to the subfolders and is hence
duplicated there.

You need to set the LOCAL module log level (settings -> mail) and
Mailboxes log level (in domain settings) to All Info and run tests. The
logs will show what exactly happens with the messages.

Urs PS: Would the action "stop processing" be of any help? I am however not
sure what effect this action precisely has. From: Graeme Fowler
<G.E.Fowler@lboro.ac.uk>
Subject: Re: Strange rule behaviour
Date: Mon, 31 Mar 2008 21:13:52 +0100
To: CommuniGate Pro Discussions <CGatePro@mail.stalker.com>
X-Mailer: Evolution 2.12.3 (2.12.3-3.fc8)



On Mon, 2008-03-31 at 21:34 +0200, Urs Grützner wrote:
Thanks for the idea, but its one rule, not two. I simply deleted the
discard action. What is weird: the on-working of the rule is random!
(actually I was
sending a mail to that account, and it worked correctly)

Are you using multiple clients for this account? Has one, by any stretch
of anyone's imagination, got a bunch of rules or filters running
locally?

Graeme



Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster