Mailing List CGatePro@mail.stalker.com Message #98375
From: Robert Brewer <rbrewer@stu.ca>
Subject: RE: upgrade
Date: Fri, 24 Jul 2009 10:17:30 -0300
To: 'CommuniGate Pro Discussions' <CGatePro@mail.stalker.com>
X-Mailer: Microsoft Office Outlook 12.0

Thanks for the help guys.  I really anticipated more discussion on this topic.  Maybe this is good news?  Perhaps it has been a good experience for upgraders in the past. 

 

Nicolas…

 

I am interested in hearing more about the server wide configuration.  I am not sure I clearly understand this.  Right now I am handling one domain on the server, to which I make domain wide changes to for certain things I want the entire domain to feel.

 

Thanks,

RB

 

 

 

From: CommuniGate Pro Discussions [mailto:CGatePro@mail.stalker.com] On Behalf Of Nicolas Hatier
Sent: July 23, 2009 4:33 PM
To: CommuniGate Pro Discussions
Subject: Re: upgrade

 



Jeff Wark wrote:

I seem to remember some issue with account aliases being handled differently in making the jump from 4 to 5 [or 5 to 5.1].  I can't remember the specifics since we don't use account aliases in more than a couple of cases.

I think it would prevent the actual server from starting if that certain error did occur.

If I remember well, that was a bug in a few specific versions which was partially corrupting the aliases file. If those specific versions are not installed, the upgrade above them should be Ok.

NH


However, unless someone else can remember this as well, you may want to attribute it to errors in my grey matter.

Nicolas Hatier wrote, at 7/23/2009 2:22 PM:

Hello

Robert Brewer wrote:


Hello folks,

 

I am planning an upgrade to CommuniGate.  I have recently renewed maintenance on the mail server, which I have taken over from a previous administrator.

 

The keys I received state that they will only work on version 5.2.3 or higher.  This is the reason for my upgrade as I am on version 4.3.9.

 

I am thinking of upgrading to the most recent 5.2.15.  I would like anyone’s opinions or thoughts on this.  As I understand from the reading I have done, I am to uninstall the previous version using the rpm from which it was installed, and then install the new version from the new rpm file.
 

Some of my questions would include…. Can I bridge that big of version gap in one upgrade?  I understand that data and any customization will not be touched.  Is that true?

Yes, you can, and yes it's true. However, some of the configuration options were moved around, from being server-wide to now be per-domain. Existing server-wide configuration will NOT be moved to the per-domain default, the factory default will apply. There is Force SMTP Auth in my mind, but there's others.

Also, if you have custom or third-party webskins, they will likely not be fully compatible with 5.2.15. They may appear to run correctly but you'll soon see undesirable side effects (handling of non-ascii characters in mailbox names, and settings pages may mostly always revert to default when saving). Third-party webskins should be updated to the latest version (make sure that latest version is fully compatible with 5.2.5 and up), and you'll have some work to do on custom webskins (you can contact me offlist if you need help with the webskins or other upgrading issues).

Apart of that, the upgrade should be quite seamless. If things goes wrong you can always quickly revert to 4.3.9 and advise (if you kept the installer).


I’d appreciate any thoughts, tips, or info on your experience, good or bad, that you figure would be helpful.

 

I am operating on RHEL 4.

 

Thanks in advance,

Rob

Best regards
Nicolas Hatier


 

 

Rob Brewer

 


-- 

*Nicolas Hatier* <nicolas.hatier@niversoft.com <mailto:nicolas.hatier@niversoft.com>>
Niversoft idées logicielles - http://www.niversoft.com

 

 

--

Nicolas Hatier <nicolas.hatier@niversoft.com>
Niversoft idées logicielles - http://www.niversoft.com

Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster