Mailing List SIMS@mail.stalker.com Message #14406
From: Michael Croft <michael@whiterose.org>
Subject: DNS routing loop error (was Re: I don't know why this bounces...)
Date: Sat, 3 Apr 2004 16:44:50 -0500
To: SIMS Discussions <SIMS@mail.stalker.com>
At 6:19 PM -0500 4/2/04, Michael Croft wrote:
>At 11:45 AM -0600 4/2/04, Kevin Windham wrote:
>>I'm not sure from this message what the precise issue is, but it does
>>appear to be DNS. Have you checked the SIMS logs for further info.
>
>I'm going to crank up the SIMS logging level and give it a try.

I'm still trying to track down the error that's causing SIMS to give an
error when Macjordomo X sends to 2 of my 30 mail list subscribers.  I've
recapped the error and my setup below, and have the relevant sections from
the sims log set level 5.  I've also contacted the other server via a test
machine, and have the results below, but I don't think I'm getting that far.

Anyone see anything that looks like it would cause a DNS routing loop
error?  any ideas that I can try next?

At 9:36 AM -0500 4/2/04, michael@whiterose.org wrote:
>Recently moved my SIMS server to a new IP/DNS provider and box.  I'm now
>running in classic on an OS X (10.3.3) machine, with Macjordomo X serving
>lists.  All is well, except that I have two users who can't receive mail
>from lists.  Plenty of others do, so I'm not sure it's SIMS.  Anyone see
>anything obvious that I can fix/investigate?  The DNS records look OK to me.
>
>
>Subject: Undeliverable mail: [hoc] Re: [Brita] In an unknown
>From: MAILER-DAEMON@mail.whiterose.org
>To: owner-hoc-l@whiterose.org
>Date: Fri, 02 Apr 2004 09:08:17 -0500
>Message-Id: <AUTOS.0004455066-4455071@mail.whiterose.org>
>X-Mailer: Stalker Internet Mail Server 1.8b9d14
>MIME-Version: 1.0
>Content-Type: multipart/report; report-type=delivery-status;
> boundary="_=receipt=_=4455071=_"
>
>--_=receipt=_=4455071=_
>Content-Type: text/plain
>
>Failed to deliver your message to mbibler@alientwister.com:
>SMTP: DNS Routing Loop
>The Domain Name System record for 'mail.whiterose.org'
>points back to 'mail.whiterose.org'.



SIMS log set to 5 for SMTP:
18:21:39 5 SMTP-085() Stream Created
18:21:39 5 SMTP(085) Resolver Created
18:21:39 4 SMTP Line 85 created for alientwister.com, [S.0004456382]
18:21:39 4 SMTP [S.0004456382] queued to line 85(0/1). 1 routes
...
18:21:39 4 SMTP-085(alientwister.com) Got 2 relay(s)
18:21:39 5 SMTP-085(alientwister.com) *Status=7
...
8:21:39 4 SMTP-085(alientwister.com) Looking for mail.whiterose.org
18:21:39 5 SMTP-085(alientwister.com) *Status=9
...
18:21:39 5 SMTP-085(alientwister.com) The highest relay is local
[216.254.119.142] - looping.
18:21:39 5 SMTP-085(alientwister.com) *Status=2
...
18:21:39 1 SYSTEM(SMTP) [S.0004456382] failed on (alientwister.com)mbibler.
Error Code=-15010
18:21:39 4 SMTP disposing line 85
18:21:39 5 SMTP(085) Resolver Disposed
18:21:39 5 SMTP-085(alientwister.com) Stream Disposed
18:21:39 3 SMTP [S.0004456382] dequeueing

My DNS records as I see them:
; <<>> DiG 9.2.2 <<>> whiterose.org mx
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25271
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;whiterose.org. IN MX

;; ANSWER SECTION:
whiterose.org. 3600 IN MX 10 mail.whiterose.org.
whiterose.org. 3600 IN MX 20 mx2.speakeasy.net.

;; Query time: 148 msec
;; SERVER: 216.254.95.2#53(216.254.95.2)
;; WHEN: Sat Apr  3 16:33:52 2004
;; MSG SIZE  rcvd: 85

; <<>> DiG 9.2.2 <<>> mail.whiterose.org
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 8519
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;mail.whiterose.org. IN A

;; ANSWER SECTION:
mail.whiterose.org. 3556 IN A 216.254.119.142

;; Query time: 13 msec
;; SERVER: 216.254.95.2#53(216.254.95.2)
;; WHEN: Sat Apr  3 16:35:48 2004
;; MSG SIZE  rcvd: 52

DNS lookup of target system:
; <<>> DiG 9.2.2 <<>> alientwister.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55781
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;alientwister.com. IN A

;; ANSWER SECTION:
alientwister.com. 874 IN A 216.37.46.188

;; Query time: 391 msec
;; SERVER: 216.254.95.2#53(216.254.95.2)
;; WHEN: Sat Apr  3 16:42:37 2004
;; MSG SIZE  rcvd: 50

No MX, so it just uses itself, which is fine, since the test below shows it
responds properly.

SMTP test connection to alientwister.com using zoneedit.com

OK, connected to alientwister.com...
< 220 loki.synergy-ent.com ESMTP
> HELO edit.dnsvr.com
< 250 loki.synergy-ent.com
> MAIL FROM:<test@mail.whiterose.org>
< 250 Ok
> RCPT TO:<mbibler@alientwister.com>
< 250 Ok
> DATA
< 354 End data with <CR><LF>.<CR><LF>
> From: test@mail.whiterose.org
> To: mbibler@alientwister.com
> Subject: ZoneEdit Automated SMTP Test (alientwister.com)
>
> If you received this, then the mail server (alientwister.com) is probably
>working.
> Sent at 2004-04-03 04:16:20 by 216.254.119.142 using Mozilla/5.0
>(Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/124 (KHTML, like Gecko)
>Safari/125.1
> .
< 250 Ok: queued as F25C3120010

--
Michael Croft       http://www.whiterose.org/michael
SAM: It's 106 miles to the Crack of Doom. We've got a magic ring,
           two daggers, it's dark, and we're wearing sunglasses
FRODO: Hit it.
Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster