Mailing List SIMS@mail.stalker.com Message #14646
From: Bill Cole <listbill@scconsult.com>
Subject: Re: Setting Up SIMS To Run Beside A Web Server
Date: Tue, 20 Jul 2004 22:37:33 -0400
To: SIMS Discussions <SIMS@mail.stalker.com>
At 11:38 AM +1000 7/21/04, Robert Dorning  imposed structure on a stream of electrons, yielding:
Despite having tried many things since my last post to this mailing list I am still unable to receive e-mail on my recently installed SIMS.

i) I have worked with my domain name registrar directnic.com to set up the MX record and A address and they say it is now set up properly. Is the following correct?

[Roberts-Computer:~] dionne% dig softdawn.net mx

;; ANSWER SECTION:
softdawn.net.           1D IN MX        10 mail.softdawn.net.

;; AUTHORITY SECTION:
softdawn.net.           1D IN NS        ns0.directnic.com.
softdawn.net.           1D IN NS        ns1.directnic.com.

;; ADDITIONAL SECTION:
mail.softdawn.net.      1D IN A         218.214.24.1

I cannot get a connection to that address on port 25.

ii) I have the domain name in SIMS set to mail.softdawn.net. I have tried receiving e-mail with, and without, the following lines in the router: mail.softdawn.net = softdawn.net and softdawn.net = mail.softdawn.net

You want the second one, not the first.


Under the SMTP Receiving Options the TCP/IP Channels is set to 25.

iii) I can make a TELNET connection to SIMS over my local network, but not from a remote computer. The error message I get on the remote is: Could not open connection to the host on port 25: Connect failed.

Over the local network I can use TELNET to send an e-mail to myself at SIMS.

That is consistent with what I see from the opposite side of the globe. I can get packets to a Swiftel router, but no further. It looks like the next hop is doing some serious filtering.

iv) I have the SIMS logs set to the highest level, but SIMS doesn't record a thing when e-mail is being sent to softdawn.net via my ISP (swiftdsl.com.au). The following is the failure notice from bounced e-mail.

<robert@softdawn.net>:
Sorry, I wasn't able to establish an SMTP connection. (#4.4.1)
I'm not going to try again; this message has been in the queue too long.

Return-Path: <softdawn@swiftdsl.com.au>
Received: (qmail 31119 invoked from network); 8 Jul 2004 05:30:47 -0000
Received: from unknown (HELO swiftdsl.com.au) ([218.214.24.1])
          (envelope-sender <softdawn@swiftdsl.com.au>)
          by tibor.swiftdsl.com.au (qmail-ldap-1.03) with SMTP
          for <robert@softdawn.net>; 8 Jul 2004 05:30:47 -0000

v) Could the problem be how my Mac 7600 (running MacOS 8.6) is set up?  File sharing is turned on.

It is something between your Mac and the routers at Swiftel. I see that www.softdawn.net points to the same IP address, but it also is not answering on port 80. Or on 548 (the TCP/IP port for file sharing... it is good not to talk to the world at large there...)

There is a very high likelihood that your problem is either on the Mac itself (i.e. in the network configuration) or in whatever router/firewall/modem you have between your Mac and your DSL provider.

Hmmmm... now I see the website up. Odd. However, the HTTP headers from your webserver tell me that you are using a NAT router of some sort, and that is almost surely the source of your trouble: you need to make that router map port 25 inbound to your SIMS server in the same way that you have it mapping port 80 inbound for your web server. The behavior I saw from it (no answer to connection attempts at all, not even a connection refusal) is perfectly consistent with a NAT router that knows that it needs to do something with that port, but is doing the wrong thing.

I have learnt a lot in my attempts to get SIMS to receive e-mail so it hasn't been a complete waste of time.

Good luck!

--
Bill Cole                                  bill@scconsult.com

Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster