Mailing List SIMS@mail.stalker.com Message #14711
From: Carl Keil <carl@snarlnet.com>
Subject: Re: problem getting SIMS to relay for my apache server
Date: Fri, 13 Aug 2004 09:27:31 -0700
To: <SIMS@mail.stalker.com>
X-Mailer: QUALCOMM Windows Eudora Version 5.1



Hi Folks,

I just switched ISP's and now a form I had working before isn't working
anymore.  It was a simple form that when you submitted it, it sent me an
email.  The mail is winding up back in my root account in pine on my Linux
box.  It doesn't seem to go anywhere else.  The error message in the email
says....

The original message was received at Thu, 12 Aug 2004 22:00:23 -0700
from apache@localhost

   ----- The following addresses had permanent fatal errors -----
carl@snarlnet.com
    (reason: 504 <apache@linuxhost>: Sender address rejected: need
fully-qualified address)


I have a user "apache" on my sims box.  I have
apache@linuxhost=carl@mail.girlwhocouldfly.com in the router
I have the IP address of my linux box set as a host that SIMS relays for.

What amd I doing wrong?  Any clues as to how I fully qualify that address?

Thanks,

ck

Message-Id: <a05111b41bd4209e57f75@[192.168.33.2]>
Date: Fri, 13 Aug 2004 01:06:11 -0500
From: billc_lists@greenbuilder.com

Does your SIMS log show the apache box trying to connect?  If so, what does it say?  Is the apache server a valid client on the SIMS box?  Check and see if you have its IP address in SMTP =>Client Addresses.



From: Bill Cole <listbill@scconsult.com>

Make Apache send with the real address, including whatever domain name is appropriate NOT just the bare hostname. SIMS is not sendmail: it will not figure out what you really mean and rewrite the address to be correct.
--
Bill Cole
bill@scconsult.com

Thanks for the replies, Bills.  Yes, SIMS shows apache trying to connect.  When I set the logger to "everything" I see about 50 lines of stuff happening.  I forget what the final verdict is.  I'll report that back.  I have apache as a client and I have the IP in Clients that SIMS relays for.

How do I get apache to send with a real address?  Is that in SendMail?  I've been using SIMS because I don't want to learn sendmail.  This was working before quite nicely.  I've looked in php.ini and the settings there all say #For Win32 only.  Not much I can set there apparently.  Any ideas what to change in SendMail config if that's the answer.  I've stuck everything I can think of in the aliases, hosts to relay for, domain masquerading, etc.

Thanks again...

ck






Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster