Mailing List SIMS@mail.stalker.com Message #15408
From: Dave Pooser <dave-stalker@pooserville.com>
Subject: Re: end of an era
Date: Tue, 06 Feb 2007 10:43:06 -0600
To: SIMS Discussions <SIMS@mail.stalker.com>
> uh oh.  Time bombs in the code?  More details please

During the Great Licensing Cluster-Fsck of 2004 Stalker began enforcing
their licensing terms which stated that they reserved the right to charge
for upgrades after the first two years. Initially, they started enforcing
those terms retroactively, so that people would have to downgrade their
CGPro versions to remain in compliance. After a public outcry, they changed
their position and announced that anybody who purchased the license was
entitled to use the latest version of 4.2.
    What they didn't say was that versions of 4.2 PRIOR to that latest
version had a timebomb in the code that would disable it on a set date
(Might have been 10/31/04, not sure). Many of us figured "ain't broke, don't
fix it" and were still running 4.2.8 or so and got bitten HARD when the
server went into trial mode and started shutting down after 10 minutes.
Stalker's reaction was to say that we got exactly what we deserved because
they'd clearly said the "latest" version and by running an earlier version
we were not complying with their amended license terms.
    Upgrading to the latest version fixed the problem, but some bitterness
remains for a lot of us.
--
Dave Pooser
Cat-Herder-in-Chief, Pooserville.com
"...Life is not a journey to the grave with the intention of arriving
safely in one pretty and well-preserved piece, but to slide across the
finish line broadside, thoroughly used up, worn out, leaking oil, and
shouting GERONIMO!!!" -- Bill McKenna


Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster