Mailing List SIMS@mail.stalker.com Message #15475
From: Bill Cole <listbill@scconsult.com>
Subject: Re: multiple IP addresses
Date: Thu, 15 Mar 2007 21:05:31 -0400
To: SIMS Discussions <SIMS@mail.stalker.com>
At 3:39 PM -0700 3/15/07, Joe Wagner  imposed structure on a stream of electrons, yielding:
On Thu, 15 Mar 2007 00:25:22 -0400 Bill Cole <listbill@scconsult.com> wrote:
But seriously, have you cranked up logging in SIMS and checked what it says at startup? There should be something like this, but with your IP's and names:
[...]
01:31:23 4 SMTP Got new Local IP addresses, n=1: [192.168.254.8], [0.0.0.0],

I cranked up logging to All for the General Server and for SMTP, and yet SIMS doesn't seem to give any acknowledgement of its IP addresses, unless I missed a setting...

That's weird. It's the SMTP module logging that, and it should do it on every startup.

Interestingly enough, this time, I now seem to be able to connect to port 8010 via the secondary IP address, but not via the primary set in the TCP/IP control panel.  Perhaps under Mac OS 9.2.2's OT, that just isn't very stable. I've used multiple IP addresses before on OS9 but those times used the same gateway or were for one upstream and one local network...

I suspect something more deterministic. Have you tried flipping the way you assign the addresses and seen if you end up with the misbehavior following the address?

I have tried adding multiple IP to my OSX server running CGPro, but the secondary address won't connect to outside requests.  My understanding form reading Sustainable Softworks's webpage, it seems OSX's setup routes all packets to the default (i.e. first) gateway:
"The Mac OS X network stack uses a single default gateway to route packets that cannot be delivered directly. "

MacOS X should not be relevant here, since its networking subsystem is a completely different beast from earlier versions. You're not trying to do this in Classic are you?

(If the answer is "yes" then I'll stop. Classic for daemons is a level of hopeless I can't focus on... )


So that would explain why I couldn't create dual access via both upstream networks on the OSX machine, but could get local access on the secondary IP.  Looks like I will have to dust off my old ipnetrouter license and upgrade. I've order USB to ethernet dongles so my iMac and mini can have dual ethernets. Sustworks' Peter has kindly put up GPL drivers for two chipsets of usb to ethernet adaptors.

I wouldn't want to discourage anyone from tossing money at Sustworks, but on those machines you might find wireless more stable and higher-performing than a USB-Ethernet gadget.
--
Bill Cole                                  bill@scconsult.com

Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster