?????? #15480 ?????? ???????? SIMS@stalker.com
?? ????: Joe Wagner <joew@cdr.stanford.edu>
????: Re: multiple IP addresses
????: Mon, 19 Mar 2007 16:05:49 -0700
????: SIMS Discussions <SIMS@mail.stalker.com>
X-Mailer: QUALCOMM Windows Eudora Version

At 15 Mar 2007 21:05:31 Bill Cole <listbill@scconsult.com> wrote:
I cranked up logging to All for the General Server and for SMTP, and yet SIMS doesn't seem to give any acknowledgement of its IP addresses, unless I missed a setting...

That's weird. It's the SMTP module logging that, and it should do it on every startup.

Well, I tried it again, and this time I did get it:
15:18:35 4 SMTP(tcp) Listener created: [], queueSize=8
15:18:35 5 SMTP Scanning 0 queue files
15:18:35 5 HTTP(tcp) Listener ReuseAddr option Error Code=0
15:18:35 4 HTTP(tcp) Listener created: [], queueSize=8

I must have had number of incoming SMPT still turned down to zero.  Dumb thing to overlook, sorry. I still did not see any other IP addresses aside from

I suspect something more deterministic. Have you tried flipping the way you assign the addresses and seen if you end up with the misbehavior following the address?

Well switching order and adding a third IP address seems to confirm that it is the last IP in the "IP Secondary" file that determines which gateway gets to talk with the outside work.  But things still didn't work consistently.  For example, pinging the continuously from the outside work would suddenly stop answering, but I'd still be able to Timbuktu into it, with a bit o'delay before it connected. In hindsight I recall was using Windows XP's ping so perhaps that gives up on a packet early...

A few times the machine would seem to hang, and I'd have to power cycle it. I wonder Comcast's network (my new connection) is polluted with machines doing pings of death or other OS9 disruptive behavior and so my debugging is hopelessly complicated with random external events.

MacOS X should not be relevant here, since its networking subsystem is a completely different beast from earlier versions. You're not trying to do this in Classic are you?

No. I'd love for that to have been possible, but from other's experience, it sounded like nothing but heartache.

I wouldn't want to discourage anyone from tossing money at Sustworks, but on those machines you might find wireless more stable and higher-performing than a USB-Ethernet gadget.

I've thought about that, but I'd read great reports of the USB gadgets and since they're cheap I'd hoped to go that route. I'd then not have to worry about radio interference (e.g. noisy motor controller for a robot) killing my connection. Plus I'd not be transmitting my users' data over the air. In any case, even using Airport, it appears I'd still need IPNetrouter to make it work.

At 16 Mar 2007 10:03:31 -0500,  Bob Smith <lists@accurateimage.org>
I've had IPNetRouter running on a Mini with one of those USB Ethernet
gadgets for about eight months now.  It serves as a gateway and DNS
server. Performs well and has run flawlessly.

Can you tell me what USB dongle you used? Today I received in the mail from Newegg a D-Link DUB-E100. Unfortunately, using Sustworks's GPL drivers (http://sustworks.com/site/news_usb_ethernet.html -- fyi) produced no joy on my 1.66 GHz Intel mini.

As a side note about power, I had recently purchased an iMac for a mail server -- I too was looking for a mini for power and noise issues, but there was a special on this iMac with maxed memory -- anyway, once installed I hooked up a power meter to it and was surprised to find it used just 35 watts. Compare that to the 300+ watts (with LCD monitor) that the old G4 digital audio desktop used...

I wish Apple had real power usage specs published on their machines. Around here in SFBay in California, after the first ~400 kwh per month, electric prices go up to $0.25 /kwh so retiring an old G4/G5 can save you over $500 a year in electricity.

??????????? (?????) ??????????? (????????) ??????????? (??????????) ?????????? ???????? Listmaster-?