Mailing List SIMS@mail.stalker.com Message #6219
From: Timothy Binder <techno@netaxs.com>
Subject: Re: Cannot resolve the domain name
Date: Mon, 12 Jun 2000 20:19:29 -0400
To: (SIMS Discussions) <SIMS@mail.stalker.com>
on 6/12/00 4:18 PM, Bill Cole at listbill@scconsult.com wrote:

> At 3:58 PM -0400 6/12/00, Timothy Binder  imposed structure on a stream of
> electrons, yielding:
>> I'm getting the following in my logs: (Ick on the word wrap, so I'm breaking
>> lines with an extra return)
>>
>> 09:29:31 2 SYSTEM [S.0000094572]
>> <21C814D77172D211AF7000A0C9CDAFFF019BAB4C@uphsex02.uphs.upenn.edu> 1+0
>> From:xxxxx@uphs.upenn.edu
>>
>> 09:30:04 1 SMTP-419(mail.krt.com) 'From' rejected, got 474
>> <xxxxx@uphs.upenn.edu> cannot resolve the domain name\r
>>
>> 09:30:04 3 SMTP [S.0000094572] delayed by mail.krt.com: 474
>> <xxxxx@uphs.upenn.edu> cannot resolve the domain name\r
>>
>> When I do an MX query on the domain, I get:
>>
>> Start: 6/12/00    3:53:59 PM
>> ;; Query: uphs.upenn.edu ,type = MX , class = ANY
>>
>> ;; ANSWERS:
>> uphs.upenn.edu.    41040    IN    MX    10  mail.uphs.upenn.edu.
>> uphs.upenn.edu.    41040    IN    MX    60  eastwood.pahosp.com.
>> uphs.upenn.edu.    41040    IN    MX    50  uphs1.uphs.upenn.edu.
>>
>> ;; AUTHORITY RECORDS:
>> uphs.upenn.edu.    79244    IN    NS    uphs1.uphs.upenn.edu.
>>
>> ;; ADDITIONAL RECORDS:
>> eastwood.pahosp.com.    172799    IN    A    198.22.219.99
>> uphs1.uphs.upenn.edu.    83530    IN    A    165.123.243.3
>>
>> * DNR Query complete 6/12/00    3:53:59 PM   *
>>
>>
>> So why can't SIMS resolve the domain? Is it because there's no A record for
>> uphs.upenn.edu? If so, does there legally have to be, since there seem to be
>> proper MX records?
>
> It does not appear to be SIMS having the problem. The SMTP session is with
> mail.krt.com and it looks like that machine is whining.

You're right. Thanks for pointing it out. The whining machine is
mail2.krt.com, which, unfortunately I'm responsible for. *It* is running
CommuniGate, so I'd expect it to behave similarly, if not the same, to SIMS.

I turned up the logs & discovered that DNS is not giving an A record for
mail.uphs.upenn.edu, so Communigate is failing on verify return path.
However, eastwood & uphs1 have A records, so should Communigate be
considered to be broken? (Vladimir?)

I've turned off verify return path for now to workaround the problem.

> I do see that at least the Sam Spade site (http://www.samspade.org) is
> getting a weird answer for the MX records: ttl=0 seconds. If you had such
> records in the DNS at some point and did not update the serial number in
> the SOA record upon a change, this could confuse some sites.

Actually, is it Sam Spade that has the problem? Every domain in which I've
tried to get MX records, I get a response of the form:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 15117
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 0
;;    concentric.net, type = MX, class = IN
concentric.net.        0S IN MX    10 mailhost.concentric.net.
concentric.net.        0S IN MX    20 franklin.concentric.net.
concentric.net.        0S IN MX    30 beasley.concentric.net.
concentric.net.        0S IN MX    40 morse.concentric.net.
concentric.net.        0S IN MX    50 buckpalace.concentric.net.

Which seems to indicate a ttl=0 for every domain I've tried, right?

> Unfortunately, I can't get the same answer from any resolver where I can
> see more than Sam Spade gives me.  I would certainly suggest that you bump
> the serial number on the zone to assure that this is not the problem, as
> that's the only thing I can think of that might cause this.

Bill,

Thanks for your input. It guided me down the right path to finding the
problem. (I was looking at the logs on the wrong server! :-)

Tim

--
"I'm a peeping Tom techy with X-ray eyes"

Subscribe (FEED) Subscribe (DIGEST) Subscribe (INDEX) Unsubscribe Mail to Listmaster